请选择 进入手机版 | 继续访问电脑版

金达牛短线伴侣 - 股市圈子

 找回密码
 立即注册
查看: 2450|回复: 70

给论坛增加人气免费和谐通达信指标,有需要和谐的可以.....

[复制链接]

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
发表于 2019-12-17 08:53:03 | 显示全部楼层 |阅读模式
免费和谐通达信指标,有需要和谐的可以发上来
金达牛短线伴侣

1

主题

19

帖子

20

积分

新手上路

Rank: 1

积分
20
发表于 2019-12-17 19:18:24 | 显示全部楼层
啥意思,是指标吗?
金达牛短线伴侣

32

主题

123

帖子

160

积分

实习版主

Rank: 7Rank: 7Rank: 7

积分
160

最佳新人活跃会员荣誉管理

发表于 2019-12-17 23:44:54 | 显示全部楼层
请老师和谐!谢谢!

梦想.zip

4.44 KB, 下载次数: 44

金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-18 04:19:00 | 显示全部楼层
拂晓 发表于 2019-12-17 23:44
请老师和谐!谢谢!

公式名称: 两点买入
参数数量: 9
参数1: RQ1, 最小: 1990, 最大: 3000, 缺省: 2019
参数2: RQ2, 最小: 1, 最大: 12, 缺省: 9
参数3: RQ3, 最小: 1, 最大: 31, 缺省: 16
参数4: RQA, 最小: 1990, 最大: 3000, 缺省: 2019
参数5: RQB, 最小: 1, 最大: 12, 缺省: 8
参数6: RQC, 最小: 1, 最大: 31, 缺省: 6
参数7: XG, 最小: 0, 最大: 3, 缺省: 2
参数8: HF, 最小: 0, 最大: 1, 缺省: 1
参数9: GF, 最小: 0, 最大: 5, 缺省: 0

RQ1: Param#0 (1990.00--3000.00)
RQ2: Param#1 (1.00--12.00)
RQ3: Param#2 (1.00--31.00)
RQA: Param#3 (1990.00--3000.00)
RQB: Param#4 (1.00--12.00)
RQC: Param#5 (1.00--31.00)
XG: Param#6 (0.00--3.00)
HF: Param#7 (0.00--1.00)
GF: Param#8 (0.00--5.00)
用法注释:无
公式源码:}
X_1:=(RQ1-1900)*10000+RQ2*100+RQ3;
X_2:=REF(HIGH,BARSLAST(DATE<=X_1));
高价:IF(DATE>=X_1 AND XG>=1,X_2,DRAWNULL),COLORYELLOW;
X_3:=(RQA-1900)*10000+RQB*100+RQC;
X_4:=REF(LOW,BARSLAST(DATE<=X_3));
DRAWTEXT(ISLASTBAR,X_2,236),COLORRED;
低价:IF(DATE>=X_3 AND XG>=1,X_4,DRAWNULL),COLORCYAN;
STICKLINE(DATE<=X_1,低价,高价,0,0),COLORGREEN;
STICKLINE(DATE<=X_3,低价,高价,0,0),COLORMAGENTA;
X_5:=(高价-(高价-X_4)*0.74806)/高价;
X_6:=(高价-(高价-X_4)*0.2609)/高价;
C1:IF(DATE>=X_3 AND XG>=2,X_2*X_6,DRAWNULL),COLORMAGENTA,LINETHICK2;
X_7:=高价*低价;
C2:SQRT(X_7),COLORMAGENTA,LINETHICK2;
C3:IF(DATE>=X_3 AND XG>=2,X_2*X_5,DRAWNULL),COLORMAGENTA,LINETHICK2;
X_8:=IF(HF,DATE<=X_1,DATE<=X_3);
DRAWNUMBER(X_8,高价*X_6*1,高价*X_6),COLORYELLOW;
DRAWNUMBER(X_8,高价*X_5*1,高价*X_5),COLORYELLOW;
DRAWNUMBER(X_8,SQRT(X_7)*1,SQRT(X_7)),COLORYELLOW;
Snipaste_2019-12-18_04-17-20.png
金达牛短线伴侣

32

主题

123

帖子

160

积分

实习版主

Rank: 7Rank: 7Rank: 7

积分
160

最佳新人活跃会员荣誉管理

发表于 2019-12-18 06:23:17 | 显示全部楼层
谢谢老师!辛苦了!
金达牛短线伴侣

2

主题

13

帖子

15

积分

新手上路

Rank: 1

积分
15
发表于 2019-12-18 11:33:39 | 显示全部楼层
请老师和谐!谢谢!

封宝山赌仓位.zip

39.68 KB, 下载次数: 44

金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-18 11:51:47 | 显示全部楼层
平平淡淡 发表于 2019-12-18 11:33
请老师和谐!谢谢!


参数1: N, 最小: 22, 最大: 125, 缺省: 45
参数2: 承担风险, 最小: 3, 最大: 20, 缺省: 10

参数精灵:
请设置计算参数:
N: Param#0 (22.00--125.00)
承担风险: Param#1 (3.00--20.00)

X_1:=IF(DATE<1200830 AND DATE>900101,1,0);
低点:IF(CURRBARSCOUNT<=N,CONST(IF(ISLASTBAR=1,LLV(LOW,BARSLAST(CURRBARSCOUNT=45)),1)),DRAWNULL),COLORRED,LINETHICK3;
X_2:=CONST(LLVBARS(LOW,45))+1=CURRBARSCOUNT;
DRAWICON(X_2,低点,34);
止损位:IF(CURRBARSCOUNT<=N,CONST(IF(ISLASTBAR=1,LLV(低点*(100-承担风险)/100,BARSLAST(CURRBARSCOUNT=45)),1)),DRAWNULL),COLORFF8000,LINETHICK3;
X_3:=((低点-低点*0.01)/CLOSE-1)*100*X_1;
DRAWTEXT_FIX(CLOSE>0,0.32,0,0,STRCAT(STRCAT(764,CON2STR(-承担风险,2)),765)),COLORYELLOW;
计划仓位:IF(承担风险/ABS(X_3)*100>=100,100-ABS(X_3),承担风险/ABS(X_3)*100),NODRAW,COLORRED;
DRAWTEXT(CURRBARSCOUNT=N,低点*1.02,STRCAT(STRCAT(766,VAR2STR(低点,2)),6)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=N,止损位*1.02,STRCAT(STRCAT(767,VAR2STR(止损位,2)),6)),COLORFF8000;
X_4:=ISLASTBAR AND 计划仓位<=6;
X_5:=ISLASTBAR AND 6<计划仓位 AND 计划仓位<15;
X_6:=ISLASTBAR AND 15<计划仓位 AND 计划仓位<25;
X_7:=ISLASTBAR AND 25<计划仓位 AND 计划仓位<35;
X_8:=ISLASTBAR AND 35<计划仓位 AND 计划仓位<45;
X_9:=ISLASTBAR AND 45<计划仓位 AND 计划仓位<55;
X_10:=ISLASTBAR AND 55<计划仓位 AND 计划仓位<65;
X_11:=ISLASTBAR AND 65<计划仓位 AND 计划仓位<75;
X_12:=ISLASTBAR AND 75<计划仓位 AND 计划仓位<85;
X_13:=ISLASTBAR AND 85<计划仓位 AND 计划仓位<95;
X_14:=ISLASTBAR AND 95<计划仓位;
DRAWGBK(X_4=1,0,0,0,768,0);
DRAWGBK(X_14=1,0,0,0,769,0);
DRAWGBK(X_13=1,0,0,0,770,0);
DRAWGBK(X_12=1,0,0,0,771,0);
DRAWGBK(X_11=1,0,0,0,772,0);
DRAWGBK(X_10=1,0,0,0,773,0);
DRAWGBK(X_9=1,0,0,0,774,0);
DRAWGBK(X_8=1,0,0,0,775,0);
DRAWGBK(X_7=1,0,0,0,776,0);
DRAWGBK(X_6=1,0,0,0,777,0);
DRAWGBK(X_5=1,0,0,0,778,0);
X_15:=LLVBARS(LOW,60);
X_16:=BARSLAST(CURRBARSCOUNT=CONST(X_15)+1);
X_17:=FINDHIGHBARS(HIGH,X_15+1,60,1);
AA1:DRAWLINE(CURRBARSCOUNT=CONST(X_17)+1,HIGH,ISLASTBAR,REF(HIGH,X_17),0),COLORYELLOW,LINETHICK2;
X_18:=BARSLAST(CURRBARSCOUNT=CONST(X_17)+1);
X_19:=CROSS(CLOSE,CONST(AA1*X_1));
X_20:=COUNT(X_19,X_18+1)=1 AND X_19;
X_21:=COUNT(VOL<MA(VOL,277),X_18+1);
X_22:=X_21/(X_18+1)*100;
X_23:=X_20 AND X_18>40 AND X_22>70;
X_24:=BARSLAST(CURRBARSCOUNT=CONST(BARSLAST(X_23))+1);
X_25:=REF(HIGH,X_18);
X_26:=REF(LOW,X_16);
X_27:=REF(CLOSE,X_24);
X_28:=(X_27-X_26)/X_26*100;
X_29:=X_28/REF(X_16,X_24);
X_30:=X_23 AND X_29<2.95;
牛线2号:DRAWLINE(X_16=0,(AA1-LOW)*0.618+LOW,ISLASTBAR,REF((AA1-LOW)*0.618+LOW,X_16),0),DOTLINE,COLORLIMAGENTA;
DRAWICON(X_30,LOW*0.95,9);
DRAWTEXT(X_16=0,LOW*0.98,749),COLORYELLOW;
X_31:=IF(CLOSE>OPEN OR (CLOSE=OPEN AND CLOSE>=REF(CLOSE,1)),VOL,0);
X_32:=IF(CLOSE<OPEN OR (CLOSE=OPEN AND CLOSE<REF(CLOSE,1)),VOL,0);
X_33:=SUM(X_31,X_16)/SUM(X_32,X_16);
X_34:=COUNT(CROSS(CLOSE>=牛线2号,0.5),X_16+1)=1 AND CROSS(CLOSE>=牛线2号,0.5) AND X_33>1.5*X_1;
DRAWICON(X_34*X_1,LOW*0.95,25);
STICKLINE(X_34*X_1,CLOSE,OPEN,2,0),COLORYELLOW;
STICKLINE(X_34*X_1,HIGH,LOW,0,0),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,AA1*0.999,STRCAT(738,CON2STR(AA1,2))),COLORYELLOW;
DRAWTEXT(X_18=0,REF(HIGH,X_18)*1.0007,VARCAT(VARCAT(702,VAR2STR(REF(HIGH,X_18),2)),6)),COLORWHITE;
X_35:=COUNT(CROSS(CLOSE>=AA1*X_1,0.5),X_18+1)=1 AND CROSS(CLOSE>=AA1*X_1,0.5) AND X_15>1.5;
DRAWICON(CROSS(CLOSE,AA1*X_1) AND CURRBARSCOUNT<CONST(X_18)+1,LOW,23);
DRAWTEXT(CURRBARSCOUNT=1,牛线2号*0.999,STRCAT(739,CON2STR(牛线2号,2))),COLORWHITE;
STICKLINE(X_35,CLOSE,OPEN,5,1),COLORLIRED;
STICKLINE(X_35,CLOSE,OPEN,0.7,1),COLORYELLOW;
ZNOTEXT1:IF(CLOSE>=AA1*X_1,AA1*X_1,DRAWNULL),COLORLIMAGENTA,LINETHICK5;
IF(CLOSE>=AA1*X_1,AA1*X_1,DRAWNULL),DOTLINE,COLORWHITE;
ZNOTEXT2:IF(CLOSE<AA1*X_1,AA1*X_1,DRAWNULL),COLORGREEN,LINETHICK2;
IF(CLOSE<AA1*X_1,AA1*X_1,DRAWNULL),DOTLINE,COLORRED;
ZNOTEXT1FF:IF(CLOSE>=牛线2号,牛线2号,DRAWNULL),COLORLIMAGENTA,LINETHICK5;
IF(CLOSE>=牛线2号,牛线2号,DRAWNULL),DOTLINE,COLORWHITE;
X_36:=10;
X_37:=REF(CLOSE,X_36)=HHV(CLOSE,2*X_36+1);
X_38:=BACKSET(X_37,X_36+1);
X_39:=FILTER(X_38,X_36) AND CLOSE=HHV(CLOSE,X_36+1);
X_40:=BARSLAST(X_39);
X_41:=IF(X_39,CURRBARSCOUNT,0);
X_42:=IF(X_40,REF(CLOSE,X_40),CLOSE);
X_43:=REF(X_42,X_40+1);
X_44:=IF(X_40,REF(X_41,X_40),X_41);
X_45:=CONST(X_44);
X_46:=REF(X_44,X_40+10);
小牛等突破:DRAWLINE(CURRBARSCOUNT=X_45,CLOSE,ISLASTBAR,REF(CLOSE,X_45-1),1),COLORRED,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=1,小牛等突破*0.999,STRCAT(123,CON2STR(小牛等突破,2))),COLORWHITE;
X_47:=BARSLAST(CURRBARSCOUNT=CONST(X_45)-1);
DRAWTEXT(X_47=0,REF(HIGH,X_47)*1.0007,VARCAT(VARCAT(779,VAR2STR(REF(HIGH,X_47),2)),6)),COLORYELLOW;
X_48:=COUNT(CROSS(CLOSE>=小牛等突破,0.5),X_18+1)=1 AND CROSS(CLOSE>=小牛等突破,0.5) AND X_15>1.5;
DRAWICON(CROSS(CLOSE,小牛等突破) AND CURRBARSCOUNT<CONST(X_18)+1,LOW,13);
STICKLINE(X_35,(OPEN+CLOSE)/2-0.01,(OPEN+CLOSE)/2+0.01,4,0),COLORGREEN;
STICKLINE(X_48,(OPEN+CLOSE)/2-0.01,(OPEN+CLOSE)/2+0.01,4,0),COLORYELLOW;
STICKLINE(X_48,CLOSE,OPEN,5,1),COLORMAGENTA;
STICKLINE(X_48,CLOSE,OPEN,0.7,1),COLORYELLOW;
ZNOTEXT11:IF(CLOSE>=小牛等突破,小牛等突破,DRAWNULL),COLORLIMAGENTA,LINETHICK5;
IF(CLOSE>=小牛等突破,小牛等突破,DRAWNULL),DOTLINE,COLORWHITE;
ZNOTEXT22:IF(CLOSE<小牛等突破,小牛等突破,DRAWNULL),COLORGREEN,LINETHICK2;
IF(CLOSE<小牛等突破,小牛等突破,DRAWNULL),DOTLINE,COLORRED;
X_49:=REF(HIGH,10)=HHV(HIGH,2*10+1);
X_50:=BACKSET(X_49,10+1);
X_51:=FILTER(X_50,10) AND HIGH=HHV(HIGH,10+1);
X_52:=BARSLAST(X_51);
X_53:=IF(X_51,CURRBARSCOUNT,0);
X_54:=IF(X_52,REF(X_53,X_52),X_53);
X_55:=CONST(X_54);
X_56:=REF(X_54,X_52+1);
X_57:=CONST(X_56);
X_58:=INTPART(3*8/5);
X_59:=REF(HIGH,X_58)=HHV(HIGH,2*X_58+1);
X_60:=FILTER(X_59,X_58);
X_61:=BACKSET(X_60,X_58+1);
X_62:=FILTER(X_61,X_58);
X_63:=BACKSET(ISLASTBAR,BARSLAST(X_62)+1);
X_64:=X_63>REF(X_63,1);
XG11QQQ:DRAWLINE(X_62,HIGH,X_64,HIGH,1),COLORGREEN,LINETHICK2;
ZNOTEXT1QQWW:IF(CLOSE>=XG11QQQ,XG11QQQ,DRAWNULL),COLORLIMAGENTA,LINETHICK5;
IF(CLOSE>=XG11QQQ,XG11QQQ,DRAWNULL),DOTLINE,COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=1,XG11QQQ*0.999,STRCAT(741,CON2STR(XG11QQQ,2))),COLORWHITE;
X_65:=COUNT(CROSS(CLOSE>=XG11QQQ,0.5),X_18+1)=1 AND CROSS(CLOSE>=XG11QQQ,0.5) AND X_15>1.5;
STICKLINE(X_65,CLOSE,OPEN,5,1),COLORWHITE;
STICKLINE(X_65,CLOSE,OPEN,0.7,0),COLORMAGENTA;
DRAWTEXT(X_65,HIGH*1.009,750),COLORYELLOW;
X_66:=CONST(LLVBARS(LOW,10));
X_67:=CONST(REF(HIGH,X_66));
X_68:=CONST(CURRBARSCOUNT);
X_69:=CONST(BARSLAST(CURRBARSCOUNT>X_68+X_66 AND HIGH>X_67));
X_70:=CONST(REF(HIGH,X_69));
X_71:=CONST(BARSLAST(CURRBARSCOUNT>X_68+X_69 AND HIGH>X_70));
X_72:=CONST(REF(HIGH,X_71));
必赢线:DRAWLINE(CURRBARSCOUNT=X_71+1,X_72,ISLASTBAR,X_72,1),COLORGREEN,LINETHICK2;
ZNOTEXT111:IF(CLOSE>=必赢线,必赢线,DRAWNULL),COLORLIMAGENTA,LINETHICK3;
IF(CLOSE>=必赢线,必赢线,DRAWNULL),DOTLINE,COLORWHITE;
ZNOTEXT222:IF(CLOSE<必赢线,必赢线,DRAWNULL),COLORGREEN,LINETHICK3;
IF(CLOSE<必赢线,必赢线,DRAWNULL),DOTLINE,COLORRED;
DRAWTEXT(CURRBARSCOUNT=1,X_72*0.999,STRCAT(780,CON2STR(X_72,2))),COLORYELLOW;
DRAWTEXT(X_35,HIGH*0.999,781),COLORYELLOW;
DRAWTEXT(X_48,HIGH*0.999,782),COLORYELLOW;
X_73:=BARSLAST(CROSS(HIGH>REF(HIGH,1) AND HIGH>REFX(HIGH,1),0.5));
X_74:=IF(X_73=0,HIGH,DRAWNULL);
X_75:=ALIGNRIGHT(X_74);
X_76:=CONST(X_75);
X_77:=BARSLAST(CROSS(X_74>X_76,0.5));
X_78:=BARSLAST(X_74=X_76);
X_79:=BARSLAST(CROSS(LOW<REF(LOW,1) AND LOW<REFX(LOW,1),0.5));
X_80:=BARSLAST(LOW=LLV(LOW,X_77+1) AND X_79=0);
X_81:=CONST(REF(LOW,X_79));
X_82:=BARSLAST(LOW=X_81);
斜率1号:DRAWLINE(CURRBARSCOUNT=CONST(X_77)+1,X_74,CURRBARSCOUNT=CONST(X_78)+1,X_76,1),COLORBLUE,LINETHICK3;
ZNOTEXT1QQ大宝:DRAWLINE(CURRBARSCOUNT=CONST(X_77)+1,X_74,CURRBARSCOUNT=CONST(X_78)+1,X_76,1),DOTLINE,COLORWHITE;
斜率2号:DRAWLINE(CURRBARSCOUNT=CONST(X_80)+1,LOW,CURRBARSCOUNT=CONST(X_82)+1,LOW,1),COLORBLUE,LINETHICK3;
ZNOTEXT1QQ小宝:DRAWLINE(CURRBARSCOUNT=CONST(X_80)+1,LOW,CURRBARSCOUNT=CONST(X_82)+1,LOW,1),DOTLINE,COLORWHITE;
DRAWNUMBER(ISLASTBAR,斜率1号,斜率1号),COLORWHITE;
DRAWNUMBER(ISLASTBAR,斜率2号,斜率2号),COLORWHITE;
X_83:=10;
X_84:=CONST(HHVBARS(VOL,X_83));
X_85:=10;
X_86:=CONST(LLVBARS(VOL,X_85));
M0:IF(CURRBARSCOUNT<=X_85+7,CONST(IF(X_86=0,OPEN,REF(OPEN,X_86))),DRAWNULL),COLORGREEN,LINETHICK4;
IF(CURRBARSCOUNT=X_86+1,M0,DRAWNULL),CIRCLEDOT,COLORYELLOW,LINETHICK3;
DRAWTEXT(CURRBARSCOUNT=1,M0*0.999,STRCAT(783,CON2STR(M0,2))),COLORYELLOW;
X_87:=COUNT(CROSS(CLOSE>=M0,0.5),X_18+1)=1 AND CROSS(CLOSE>=M0,0.5) AND X_15>1.5;
ZNOTEXT1QQ:IF(CLOSE>=M0,M0,DRAWNULL),COLORLIMAGENTA,LINETHICK5;
IF(CLOSE>=M0,M0,DRAWNULL),DOTLINE,COLORWHITE;
STICKLINE(X_87,CLOSE,OPEN,5,1),COLORWHITE;
STICKLINE(X_87,CLOSE,OPEN,0.7,1),COLORGREEN;
DRAWTEXT(X_87,HIGH*0.999,784),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.14,0,STRCAT(90,EXTERNSTR(0,2001))),COLORWHITE;
DRAWTEXT_FIX(1,0,0.17,0,STRCAT(STRCAT(STRCAT(STRCAT(EXTERNSTR(0,9882),91),EXTERNSTR(0,9883)),92),EXTERNSTR(0,9884))),COLORYELLOW;
DRAWTEXT_FIX(1,0.3,0.1,0,STRCAT(STRCAT(STRCAT(STRCAT(EXTERNSTR(0,2000),94),EXTERNSTR(0,2008)),751),EXTERNSTR(0,1100))),COLORAFFF00;
X_88:=CLOSE/REF(CLOSE,3)>=1.1;
X_89:=BACKSET(X_88,3);
X_90:=TROUGHBARS(3,10,1)<4;

金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-18 11:52:09 | 显示全部楼层
平平淡淡 发表于 2019-12-18 11:33
请老师和谐!谢谢!

和上面的代码是一起的哦


X_91:=X_89 AND X_90 AND COUNT(X_89,3)=1*X_1;
STICKLINE(X_91,CLOSE,OPEN,4,0),COLORLIBLUE;
STICKLINE(X_91,HIGH,LOW,1,1),COLORWHITE;
DRAWTEXT(X_91=1,LOW*0.98,785),COLORYELLOW;
DRAWLINE(X_89=1,LOW,X_91,REF(LOW,X_89),0),DOTLINE,COLORWHITE;
X_92:=REF(HIGH,3)=HHV(HIGH,2*3+1);
X_93:=FILTER(X_92,3);
X_94:=BACKSET(X_93,3+1);
X_95:=FILTER(X_94,3);
X_96:=REF(LOW,3)=LLV(LOW,2*3+1);
X_97:=FILTER(X_96,3);
X_98:=BACKSET(X_97,3+1);
X_99:=FILTER(X_98,3);
X_100:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
X_101:=(HIGH+LOW)/2;
X_102:=X_95 AND NOT(X_99 AND X_100>=X_101) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X_103:=X_95 AND NOT(X_99 AND X_100>=X_101);
X_104:=X_99 AND NOT(X_95 AND X_100=X_101);
X_105:=REF(BARSLAST(X_102),1)+1;
X_106:=BACKSET(X_102 AND COUNT(X_104,X_105)>0,LLVBARS(IF(X_104,LOW,10000),X_105));
X_107:=X_106>REF(X_106,1);
X_108:=BACKSET(X_107,2);
X_109:=X_108>REF(X_108,1);
X_110:=X_109 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X_111:=REF(BARSLAST(X_110),1)+1;
X_112:=BACKSET(X_110 AND COUNT(X_103,X_111)>0,HHVBARS(IF(X_103,HIGH,0),X_111));
X_113:=X_112>REF(X_112,1);
X_114:=BACKSET(X_113,2);
X_115:=X_114>REF(X_114,1);
X_116:=BACKSET(ISLASTBAR,BARSLAST(X_109)+1);
X_117:=X_116>REF(X_116,1);
X_118:=BACKSET(ISLASTBAR,BARSLAST(X_115)+1);
X_119:=X_118>REF(X_118,1);
底:REF(LOW,BARSLAST(X_117)),COLORRED,LINETHICK3;
顶:REF(HIGH,BARSLAST(X_119)),COLORGREEN,LINETHICK3;
STICKLINE(X_117,顶,底,0.1,0),COLORYELLOW,LINETHICK3;
DRAWLINE(X_119,HIGH,X_117,LOW,0),COLORYELLOW,LINETHICK3;
DRAWLINE(X_119,HIGH,X_117,顶,0),COLORYELLOW,LINETHICK3;
DRAWTEXT(ISLASTBAR,顶,STRCAT(369,CON2STR(顶,2))),COLORGREEN;
DRAWTEXT(ISLASTBAR,底,STRCAT(369,CON2STR(底,2))),COLORRED;
STICKLINE(X_119,顶,底,0.1,0),COLORFF8000,LINETHICK3;
DRAWLINE(X_117,LOW,X_119,HIGH,0),COLORFF8000,LINETHICK3;
DRAWLINE(X_117,LOW,X_119,底,0),COLORFF8000,LINETHICK3;
X_120:=COUNT(CROSS(CLOSE>=顶,0.5),X_117+1)=1 AND CROSS(CLOSE>=顶,0.5) AND 底>1.5;
DRAWTEXT(X_120=1,LOW,786),COLORWHITE;
X_121:=COUNT(CROSS(CLOSE>=底,0.5),X_119+1)=1 AND CROSS(CLOSE>=底,0.5) AND 底>1.5;
DRAWTEXT(X_121=1,LOW,787),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,CODE);
12313123.png
金达牛短线伴侣

2

主题

13

帖子

15

积分

新手上路

Rank: 1

积分
15
发表于 2019-12-18 16:25:50 | 显示全部楼层
请老师和谐

封宝山赌仓位.zip

39.68 KB, 下载次数: 31

金达牛短线伴侣

2

主题

13

帖子

15

积分

新手上路

Rank: 1

积分
15
发表于 2019-12-18 16:52:48 | 显示全部楼层
老师当前公式 : 自用仓位 (画线指标公式)  
错误句 :
AA1RAWLINE(CURRBARSCOUNT=CONST(X_17)+1,HIGH,ISLASTBAR,REF(HIGH,X_17),0),COLORYELLOW,LINETHICK2
详细信息 : 您在括号前写的不是函数、公式等,
且缺少必要的运算符!
错误起始位置 : 1724 ; 长度: 12
金达牛短线伴侣

2

主题

13

帖子

15

积分

新手上路

Rank: 1

积分
15
发表于 2019-12-18 16:57:05 | 显示全部楼层
没有AA1
金达牛短线伴侣
回复

使用道具 举报

2

主题

5

帖子

6

积分

新手上路

Rank: 1

积分
6
发表于 2019-12-18 17:41:13 | 显示全部楼层
老师当前公式 : 自用仓位 (画线指标公式)  
错误句 :
AA1RAWLINE(CURRBARSCOUNT=CONST(X_17)+1,HIGH,ISLASTBAR,REF(HIGH,X_17),0),COLORYELLOW,LINETHICK2
详细信息 : 您在括号前写的不是函数、公式等,
且缺少必要的运算符!
错误起始位置 : 1724 ; 长度: 12
金达牛短线伴侣

2

主题

13

帖子

15

积分

新手上路

Rank: 1

积分
15
发表于 2019-12-18 18:42:19 | 显示全部楼层
老师请将公式发出来,谢谢
金达牛短线伴侣

2

主题

13

帖子

15

积分

新手上路

Rank: 1

积分
15
发表于 2019-12-18 18:51:10 | 显示全部楼层
老师这几处不行啊,请老师指点,谢谢

捕获1.PNG
捕获2.PNG
捕获3.PNG
捕获4.PNG
金达牛短线伴侣

0

主题

1

帖子

1

积分

新手上路

Rank: 1

积分
1
发表于 2019-12-18 19:32:56 | 显示全部楼层
看规律自己填差的东西
金达牛短线伴侣
发表于 2019-12-18 21:28:01 | 显示全部楼层
金指头 发表于 2019-12-18 11:52
和上面的代码是一起的哦

代码有很多错误
金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-19 08:45:37 | 显示全部楼层
平平淡淡 发表于 2019-12-18 18:51
老师这几处不行啊,请老师指点,谢谢

这个是文版的源码,你看看

2019-12-18_11-48-58_封宝山赌仓位_.rar

3.1 KB, 下载次数: 69

金达牛短线伴侣

32

主题

123

帖子

160

积分

实习版主

Rank: 7Rank: 7Rank: 7

积分
160

最佳新人活跃会员荣誉管理

发表于 2019-12-19 10:46:01 | 显示全部楼层
感谢金指头老师的辛苦付出!
金达牛短线伴侣

32

主题

123

帖子

160

积分

实习版主

Rank: 7Rank: 7Rank: 7

积分
160

最佳新人活跃会员荣誉管理

发表于 2019-12-19 11:35:24 | 显示全部楼层
请老师和谐!谢谢!

实战突破跟踪主图套装.zip

59.89 KB, 下载次数: 40

金达牛短线伴侣

0

主题

3

帖子

3

积分

新手上路

Rank: 1

积分
3
发表于 2019-12-19 12:37:21 | 显示全部楼层
我这里倒是有个 ,先谢谢

KDJ共振指标.zip

10.82 KB, 下载次数: 25

金达牛短线伴侣

1

主题

7

帖子

8

积分

新手上路

Rank: 1

积分
8
发表于 2019-12-19 12:43:12 | 显示全部楼层
源码上有表情通不过
金达牛短线伴侣

0

主题

12

帖子

12

积分

新手上路

Rank: 1

积分
12
发表于 2019-12-19 12:55:18 | 显示全部楼层
这个指标隔天就需要重新安装,老师帮忙看看呢

乾坤无极线—高铭.rar

3.12 KB, 下载次数: 30

金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-19 19:03:44 | 显示全部楼层
mrr.xu 发表于 2019-12-19 12:55
这个指标隔天就需要重新安装,老师帮忙看看呢

DRAWTEXT_FIX(ISLASTBAR,0.005,0.15,0,GNBLOCK),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.005,0,FGBLOCK),COLORWHITE;
市净率:=STRCAT('市净率:',CON2STR(C/FINANCE(34),2));
市盈率:=STRCAT('市盈率:',CON2STR(DYNAINFO(39),2));
市值:=STRCAT(STRCAT('流通市值:',CON2STR((CAPITAL/1000000)*C,2)),'亿');
股本市值:=STRCAT('',STRCAT(市净率,市值));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.07,0,STRCAT(市盈率 ,股本市值)),COLORMAGENTA;



乾:MA(CLOSE,10),LINETHICK1,COLORWHITE;
坤:MA(CLOSE,29),LINETHICK1,COLORYELLOW;
无极线:MA(C,5);
IF(无极线>=REF(无极线,1),无极线,DRAWNULL),COLORRED,LINETHICK2;
IF(无极线<REF(无极线,1),无极线,DRAWNULL),COLORGREEN,LINETHICK2;

VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买入'),COLORRED;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖1>0,HIGH*1.02,'卖出'),COLORGREEN;

VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
F:IF(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLOREE00EE;


涨停:STICKLINE(C>1.099*REF(C,1),O,H,0.3,0),COLORYELLOW;



Snipaste_2019-12-19_19-03-22.png
金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-19 19:05:04 | 显示全部楼层
金指头 发表于 2019-12-19 19:03
DRAWTEXT_FIX(ISLASTBAR,0.005,0.15,0,GNBLOCK),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.005,0,FGBLO ...

需要把里面的时间限制给去掉,你的指标有时间限制并且已经过期了,所以才导致你的问题
金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-19 19:07:49 | 显示全部楼层
拂晓 发表于 2019-12-19 11:35
请老师和谐!谢谢!








突破跟踪.rar

4.19 KB, 下载次数: 46

金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-19 19:09:36 | 显示全部楼层
dzb123 发表于 2019-12-19 12:37
我这里倒是有个 ,先谢谢

公式源码:}
X_1:=1;
日K:KDJ.K,COLORWHITE;
日D:KDJ.D,COLORYELLOW;
日J:KDJ.J,COLORMAGENTA;
X_2:=KDJ.K#WEEK;
X_3:=KDJ.D#WEEK;
X_4:=KDJ.J#WEEK;
X_5:=CROSS(日K,日D) AND (日D<40 OR 日D>60);
X_6:=CROSS(X_2,X_3) AND (X_3<40 OR X_3>60);
X_7:=X_6 AND X_5;
STICKLINE(X_7,(-30),100,3,0),COLORLIRED;
DRAWTEXT(X_6 AND X_5,(-5),254),COLORYELLOW;
DRAWTEXT(X_6 AND X_5,5,255),COLORYELLOW;
DRAWICON(X_6 AND X_5,(-5),5);
STICKLINE(日K>=日D,(-15),(-10),3,0),COLORLIRED;
STICKLINE(日K<日D,(-15),(-10),3,0),COLORLIBLUE;
STICKLINE(X_2>=X_3,(-20),(-25),3,0),COLORLIRED;
STICKLINE(X_2<X_3,(-20),(-25),3,0),COLORLIBLUE;
DRAWTEXT(ISLASTBAR,(-12),256),COLORWHITE;
DRAWTEXT(ISLASTBAR,(-22),257),COLORWHITE;
X_8:=REF(CLOSE,1);
X_9:=SMA(MAX(CLOSE-X_8,0),6,1)/SMA(ABS(CLOSE-X_8),6,1)*100;
X_10:=SMA(MAX(CLOSE-X_8,0),12,1)/SMA(ABS(CLOSE-X_8),12,1)*100;
DRAWBAND(X_9,RGB(150,0,0),X_10,RGB(0,0,150));
RSI1:SMA(MAX(CLOSE-X_8,0),6,1)/SMA(ABS(CLOSE-X_8),6,1)*100,COLOR000096;
RSI2:SMA(MAX(CLOSE-X_8,0),12,1)/SMA(ABS(CLOSE-X_8),12,1)*100,COLOR000096;
IF(RSI1>RSI2,DRAWNULL,RSI1),COLOR960000;
IF(RSI1>RSI2,DRAWNULL,RSI2),COLOR960000;
X_11:=BARSLAST(REF(CROSS(KDJ.K(9,3,3),KDJ.D(9,3,3)),1));
X_12:=REF(CLOSE,X_11+1)>CLOSE AND REF(KDJ.K(9,3,3),X_11+1)<KDJ.K(9,3,3) AND CROSS(KDJ.K(9,3,3),KDJ.D(9,3,3));
X_13:=BARSLAST(REF(CROSS(KDJ.D(9,3,3),KDJ.K(9,3,3)),1));
X_14:=REF(CLOSE,X_13+1)<CLOSE AND REF(KDJ.K(9,3,3),X_13+1)>KDJ.K(9,3,3) AND CROSS(KDJ.D(9,3,3),KDJ.K(9,3,3));
DRAWICON(X_12>0,日J,1);
DRAWTEXT(X_12>0,日J,258),COLORWHITE;
DRAWICON(X_14>0,日J,2);
DRAWTEXT(X_14>0,日J,259),COLORGREEN;
X_15:=BARSLAST(REF(CROSS(RSI.RSI1(6,12,24),RSI.RSI2(6,12,24)),1));
X_16:=REF(CLOSE,X_15+1)>CLOSE AND REF(RSI.RSI1(6,12,24),X_15+1)<RSI.RSI1(6,12,24) AND CROSS(RSI.RSI1(6,12,24),RSI.RSI2(6,12,24));
X_17:=BARSLAST(REF(CROSS(RSI.RSI2(6,12,24),RSI.RSI1(6,12,24)),1));
X_18:=REF(CLOSE,X_17+1)<CLOSE AND REF(RSI.RSI1(6,12,24),X_17+1)>RSI.RSI1(6,12,24) AND CROSS(RSI.RSI2(6,12,24),RSI.RSI1(6,12,24));
DRAWICON(X_18>0,95,2);
DRAWTEXT(X_18>0,95,260),COLORCYAN;
DRAWICON(X_16>0,20,1);
DRAWTEXT(X_16>0,20,261),COLORRED;
X_19:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(X_19,3,1),COLORWHITE;
D:SMA(K,3,1),COLORYELLOW;
J:3*K-2*D,COLORMAGENTA;
IF1:IF(J<10,J,DRAWNULL),COLORRED,LINETHICK2;
IF2:IF(J>=80,J,DRAWNULL),COLORFF0080,LINETHICK2;
DRAWTEXT(ISLASTBAR,K,262),COLORWHITE;
DRAWTEXT(ISLASTBAR,D,263),COLORYELLOW;
DRAWTEXT(ISLASTBAR,J,264),COLORMAGENTA;
金达牛短线伴侣

32

主题

123

帖子

160

积分

实习版主

Rank: 7Rank: 7Rank: 7

积分
160

最佳新人活跃会员荣誉管理

发表于 2019-12-19 19:45:08 | 显示全部楼层
谢谢老师!
金达牛短线伴侣
回复

使用道具 举报

0

主题

3

帖子

3

积分

新手上路

Rank: 1

积分
3
发表于 2019-12-19 20:34:30 | 显示全部楼层
有未来函数就不要麻烦老师破解哈
金达牛短线伴侣

32

主题

123

帖子

160

积分

实习版主

Rank: 7Rank: 7Rank: 7

积分
160

最佳新人活跃会员荣誉管理

发表于 2019-12-19 21:07:17 | 显示全部楼层
lkair 发表于 2019-12-19 20:34
有未来函数就不要麻烦老师破解哈

有道理 ,支持
金达牛短线伴侣

1

主题

19

帖子

20

积分

新手上路

Rank: 1

积分
20
发表于 2019-12-21 00:30:08 | 显示全部楼层
不错,顶起来!
金达牛短线伴侣

0

主题

12

帖子

12

积分

新手上路

Rank: 1

积分
12
发表于 2019-12-21 11:58:54 | 显示全部楼层
谢谢老师
金达牛短线伴侣
回复

使用道具 举报

5

主题

9

帖子

14

积分

新手上路

Rank: 1

积分
14
发表于 2019-12-21 16:47:58 | 显示全部楼层
顶·起来
金达牛短线伴侣
回复

使用道具 举报

0

主题

7

帖子

20

积分

新手上路

Rank: 1

积分
20
发表于 2019-12-22 15:02:21 | 显示全部楼层
顶·起来,谢谢老师
金达牛短线伴侣

0

主题

3

帖子

3

积分

新手上路

Rank: 1

积分
3
发表于 2019-12-23 09:11:10 | 显示全部楼层
谢谢老师 !!!
金达牛短线伴侣
回复

使用道具 举报

0

主题

7

帖子

20

积分

新手上路

Rank: 1

积分
20
发表于 2019-12-23 22:09:50 | 显示全部楼层
金指头 发表于 2019-12-18 04:19
公式名称: 两点买入
参数数量: 9
参数1: RQ1, 最小: 1990, 最大: 3000, 缺省: 2019

您好,老师。公式不全吧。请老师弄一下谢谢了!
金达牛短线伴侣

0

主题

2

帖子

2

积分

新手上路

Rank: 1

积分
2
发表于 2019-12-25 01:19:58 | 显示全部楼层
五星磁浮.rar (21.23 KB, 下载次数: 31)
金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-26 07:25:13 | 显示全部楼层
菜鸟 发表于 2019-12-25 01:19
请老师和谐,谢谢

{公式名称: 五星磁附主图
公式描述:
参数数量: 5
参数1: M1, 最小: 1, 最大: 1000, 缺省: 11
参数2: M2, 最小: 1, 最大: 1000, 缺省: 22
参数3: M3, 最小: 1, 最大: 1000, 缺省: 77
参数4: M4, 最小: 1, 最大: 1000, 缺省: 99
参数5: N, 最小: 0, 最大: 1000, 缺省: 10
公式类型: 技术指标公式-路径型
画线方法: 主图叠加
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:
请设置计算参数:
M1: Param#0 (1.00--1000.00)
M2: Param#1 (1.00--1000.00)
M3: Param#2 (1.00--1000.00)
M4: Param#3 (1.00--1000.00)
N: Param#4 (0.00--1000.00)
用法注释:
1、黄蝴蝶表示关注,即关注操盘机会;
2、红加号表示建仓,大胆搞,一定没错;
3、黄的上涨箭头,表示加仓,大胆加,一定有惊喜。
4、如何卖出,结合CCI等指标决定。

公式源码:}
X_1:=Func_0x7636.SubValue_0x5;
X_2:=Func_0x7636.SubValue_0x1B;
X_3:=Func_0x7636.SubValue_0x1C;
X_4:=Func_0x7632.SubValue_0x5C;
X_5:=Func_0x7631.SubValue_0x12;
X_6:=Func_0x7631.SubValue_0x13;
X_7:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
X_8:=REF(X_7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_9:=REF(X_8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_10:=REF(X_9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_11:=REF(X_10,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_12:=REF(X_11,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_13:=REF(X_12,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_14:=REF(X_13,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_15:=REF(X_14,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_16:=REF(X_15,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_17:=REF(X_16,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_18:=REF(X_17,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_19:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
X_20:=REF(X_19,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_21:=REF(X_20,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_22:=REF(X_21,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_23:=REF(X_22,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_24:=REF(X_23,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_25:=REF(X_24,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_26:=REF(X_25,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_27:=REF(X_26,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_28:=REF(X_27,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_29:=REF(X_28,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_30:=REF(X_29,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_31:=REF(X_19 OR X_20 OR X_21 OR X_22 OR X_23 OR X_24 OR X_25 OR X_26 OR X_27 OR X_28 OR X_29 OR X_30,1) AND X_7;
X_32:=REF(X_7 OR X_8 OR X_9 OR X_10 OR X_11 OR X_12 OR X_13 OR X_14 OR X_15 OR X_16 OR X_17 OR X_18,1) AND X_19;
X_33:=IF(X_31>0,1,0);
X_34:=IF(X_32>0,1,0);
X_35:=IF(X_7 OR X_8 OR X_9 OR X_10 OR X_11 OR X_12 OR X_13 OR X_14 OR X_15 OR X_16 OR X_17 OR X_18,1,0);
X_36:=IF((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<(-14),1,0);
X_37:=IF(X_33=0 AND X_34=0 AND X_35=0 AND X_36=0,1,DRAWNULL);
X_38:=IF(Func_0x763C.SubValue_0x0>0,1,0);
X_39:=CONST(IF(X_33>0,0,IF(X_34>0,0,IF(X_35>0,150,IF(X_36>0,100,1)))));
X_40:=CONST(IF(X_33>0,150,IF(X_34>0,20,IF(X_35>0,0,IF(X_36>0,100,1)))));
X_41:=CONST(IF(X_33>0,0,IF(X_34>0,150,IF(X_35>0,20,IF(X_36>0,100,1)))));
DRAWGBK(CLOSE>0 AND X_38=1,RGB(X_39,X_40,X_41),RGB(0,0,0),0,X_4,0);
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
三日:MA(CLOSE,3),DOTLINE,COLORWHITE;
MA1:MA(CLOSE,M1),COLORWHITE;
MA2:MA(CLOSE,M2),COLORYELLOW;
MA3:MA(CLOSE,M3),COLORMAGENTA,LINETHICK2;
MA4:MA(CLOSE,M4),COLORGREEN,LINETHICK2;
X_42:=MA1>MA2 AND MA3>MA4 AND CROSS(MA1,MA4) AND REF(MA1<MA4,1);
X_43:=MA1>MA2 AND MA3>MA4 AND CROSS(MA2,MA4) AND REF(MA2<MA4,1);
X_44:=MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND MA4>REF(MA4,1);
X_45:=MA1>MA2 AND MA3>MA4 AND MA1<MA4;
DRAWICON(X_42,LOW*0.999,23);
DRAWICON(X_43,LOW*0.999,34);
DRAWICON(X_44 AND X_45,LOW*0.9999,29);
X_46:=REF(HIGH,N)=HHV(HIGH,2*N+1);
X_47:=FILTER(X_46,N);
X_48:=BACKSET(X_47,N+1);
X_49:=FILTER(X_48,N);
X_50:=BACKSET(CURRBARSCOUNT=2,BARSLAST(X_49)+1);
X_51:=X_50>REF(X_50,1);
阶段最高:REF(HIGH,BARSLAST(X_51)),COLORGREEN;
高点收盘:REF(CLOSE,BARSLAST(X_51)),DOTLINE,COLORGREEN;
DRAWTEXT(ISLASTBAR,阶段最高,VARCAT(VAR2STR(阶段最高,2),X_1)),COLORWHITE;
DRAWTEXT(REF(阶段最高,1)=DRAWNULL AND 阶段最高>0,HIGH*0.99,X_5),COLORCYAN;
DRAWTEXT(ISLASTBAR,高点收盘,VARCAT(VAR2STR(高点收盘,2),X_1)),COLORWHITE;
X_52:=REF(LOW,N)=LLV(LOW,2*N+1);
X_53:=FILTER(X_52,N);
X_54:=BACKSET(X_53,N+1);
X_55:=FILTER(X_54,N);
X_56:=BACKSET(CURRBARSCOUNT=2,BARSLAST(X_55)+1);
X_57:=X_56>REF(X_56,1);
阶段最低:REF(LOW,BARSLAST(X_57)),COLORMAGENTA;
低点收盘:REF(CLOSE,BARSLAST(X_57)),DOTLINE,COLORMAGENTA;
DRAWTEXT(ISLASTBAR,阶段最低,VARCAT(VAR2STR(阶段最低,2),X_1)),COLORRED;
DRAWTEXT(REF(阶段最低,1)=DRAWNULL AND 阶段最低>0,LOW*1.01,X_6),COLORYELLOW;
DRAWTEXT(ISLASTBAR,低点收盘,VARCAT(VAR2STR(低点收盘,2),X_1)),COLORRED;
厢体中位阶段最高+阶段最低)/2,CIRCLEDOT,COLORYELLOW;
DRAWTEXT(ISLASTBAR,厢体中位,VARCAT(VAR2STR(厢体中位,2),X_1)),COLORYELLOW;
X_58:=CODELIKE(754);
X_59:=CODELIKE(755);
X_60:=CODELIKE(756);
X_61:=X_58=0 AND X_59=0 AND X_60=0;
X_62:=Func_0x7631.SubValue_0x32;
X_63:=Func_0x7631.SubValue_0x33;
X_64:=Func_0x7631.SubValue_0x34;
X_65:=FINVALUE(285);
X_66:=FINVALUE(286);
DRAWTEXT_FIX(X_61>0 AND ISLASTBAR,0.01,0.01,0,STRCAT(X_62,STRCAT(CON2STR(X_65,2),STRCAT(X_63,STRCAT(CON2STR(X_66,2),X_64))))),COLORCYAN;
X_67:=FINVALUE(239)/100000000;
X_68:=FINVALUE(284)/10000;
X_69:=X_68/X_67*100;
X_70:=X_68-REF(X_68,1);
X_71:=Func_0x763D.SubValue_0x40;
X_72:=Func_0x763D.SubValue_0x41;
X_73:=Func_0x7631.SubValue_0x36;
X_74:=Func_0x7631.SubValue_0x37;
X_75:=Func_0x7631.SubValue_0x38;
X_76:=Func_0x7631.SubValue_0x39;
DRAWTEXT_FIX(X_61>0 AND ISLASTBAR,0.01,0.06,0,STRCAT(X_73,STRCAT(VAR2STR(X_68,2),STRCAT(X_74,STRCAT(X_76,STRCAT(VAR2STR(X_69,2),STRCAT(X_3,STRCAT(IF(1 AND X_70>0,X_71,DRAWNULL),STRCAT(IF(1 AND X_70>0,VAR2STR(X_70*10000,2),DRAWNULL),X_75))))))))),COLORGREEN;
DRAWTEXT_FIX(X_61>0 AND ISLASTBAR,0.01,0.06,0,STRCAT(X_73,STRCAT(VAR2STR(X_68,2),STRCAT(X_74,STRCAT(X_76,STRCAT(VAR2STR(X_69,2),STRCAT(X_3,STRCAT(IF(1 AND X_70<0,X_72,DRAWNULL),STRCAT(IF(1 AND X_70>0,VAR2STR((-X_70)*10000,2),DRAWNULL),X_75))))))))),COLORGREEN;
X_77:=Func_0x7631.SubValue_0x2C;
X_78:=Func_0x7631.SubValue_0x35;
DRAWTEXT_FIX(X_61>0 AND 1,0.01,0.11,0,STRCAT(X_77,STRCAT(EXTERNSTR(0,187),STRCAT(X_4,STRCAT(X_4,STRCAT(X_78,EXTERNSTR(0,188))))))),COLORYELLOW;
X_79:=Func_0x763D.SubValue_0x42;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.95,0,X_79),COLOR009900;
金达牛短线伴侣

1

主题

11

帖子

12

积分

新手上路

Rank: 1

积分
12
发表于 2019-12-26 17:21:58 | 显示全部楼层
怎么上传附件。
金达牛短线伴侣

1

主题

11

帖子

12

积分

新手上路

Rank: 1

积分
12
发表于 2019-12-26 17:24:00 | 显示全部楼层
谢谢。。。。。。。。。。。。。。

妖股引用_0.rar

4.04 KB, 下载次数: 15

金达牛短线伴侣
回复

使用道具 举报

2

主题

7

帖子

9

积分

新手上路

Rank: 1

积分
9
发表于 2019-12-26 20:38:11 | 显示全部楼层
求和谐。、感谢版主

开盘预警涨停.rar

1.51 KB, 下载次数: 23

金达牛短线伴侣

2

主题

7

帖子

9

积分

新手上路

Rank: 1

积分
9
发表于 2019-12-26 20:39:55 | 显示全部楼层
求版主和谐、感谢版主

涨停缩量均线.rar

2.92 KB, 下载次数: 16

金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-26 21:03:57 | 显示全部楼层
admsinadm 发表于 2019-12-26 17:24
谢谢。。。。。。。。。。。。。。

OUT:SIGNALS_USER(603,0)>0;
FK:INTPART(SIGNALS_USER(604,0));
X_1:=OUT OR OUT AND 1;
X_2:=REF(CLOSE,1);
X_3:=SMA(MAX(CLOSE-X_2,0),2,1)/SMA(ABS(CLOSE-X_2),2,1)*100;
X_4:=SMA(MAX(CLOSE-X_2,0),14,1)/SMA(ABS(CLOSE-X_2),14,1)*100;
X_5:=45;
X_6:=50;
X_7:=80;
X_8:=20;
X_9:=5;
X_10:=REF(CLOSE,1);
X_11:=IF(REF(CLOSE,1)*1.1-CLOSE<0.01,1,0);
X_12:=X_3<X_6 AND REF(X_3,1)>X_6;
X_13:=X_3<X_5 AND REF(X_3,1)>X_5;
X_14:=X_3<X_8 AND REF(X_3,1)>X_8;
X_15:=COUNT(X_11,13)>=1;
X_16:=SMA(LOW,4,3);
X_17:=X_16 AND REF(X_13,1) AND X_15;
X_18:=X_16 AND REF(X_14,1) AND X_15;
X_19:=X_17 OR X_18;
X_20:=REF(EXIST(X_1,7),1) AND X_19;
YGHTOUT:X_20 AND NOT(REF(EXIST(X_20,20),1));
JGLX:IF(SIGNALS_USER(508,0)/10000>70,30,SIGNALS_USER(508,0)/10000);
YZLX:IF(SIGNALS_USER(504,0)/10000>70,30,SIGNALS_USER(504,0)/10000);
金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-26 21:04:58 | 显示全部楼层
起爆 发表于 2019-12-26 20:38
求和谐。、感谢版主

公式源码:}
X_1:=EXIST((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5.6,100);
X_2:=DYNAINFO(17)=0;
X_3:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_4:=VOL/REF(MA(VOL,5),1);
X_5:=CAPITAL/1000000;
X:X_3>3 AND X_4>2 AND X_5<1;
金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-26 21:06:08 | 显示全部楼层
起爆 发表于 2019-12-26 20:39
求版主和谐、感谢版主

公式源码:}
X_1:=VOL/CAPITAL*100;
X_2:=CLOSE/REF(CLOSE,1)>1.095;
X_3:=REF(X_2,3);
X_4:=REF(X_2,4);
X_5:=REF(X_2,5);
X_6:=REF(X_2,6);
X_7:=REF(X_2,7);
X_8:=REF(X_2,8);
X_9:=REF(X_2,9);
X_10:=REF(X_2,10);
X_11:=REF(X_2,11);
X_12:=REF(X_2,12);
X_13:=REF(X_2,13);
X_14:=REF(X_2,14);
X_15:=REF(X_2,15);
X_16:=CLOSE>OPEN AND CLOSE>EMA(CLOSE,12) AND LOW<EMA(CLOSE,12) AND VOL<REF(VOL,1);
XG:X_3 AND X_16 OR X_4 AND X_16 OR X_5 AND X_16 OR X_6 AND X_16 OR X_7 AND X_16 OR X_8 AND X_16 OR X_9 AND X_16 OR X_10 AND X_16 OR X_11 AND X_16 OR X_12 AND X_16 OR X_13 AND X_16 OR X_4 AND X_16 OR X_15 AND X_16;
金达牛短线伴侣

2

主题

7

帖子

9

积分

新手上路

Rank: 1

积分
9
发表于 2019-12-26 21:09:14 | 显示全部楼层
金指头 发表于 2019-12-26 21:06
公式源码:}
X_1:=VOL/CAPITAL*100;
X_2:=CLOSE/REF(CLOSE,1)>1.095;

麻烦您啦。祝您股市长虹
金达牛短线伴侣

0

主题

2

帖子

2

积分

新手上路

Rank: 1

积分
2
发表于 2019-12-26 21:19:15 | 显示全部楼层
金指头 发表于 2019-12-26 07:25
{公式名称: 五星磁附主图
公式描述:
参数数量: 5

老师,这个通过不了呢?
QQ图片20191226211811.png
金达牛短线伴侣

1

主题

11

帖子

12

积分

新手上路

Rank: 1

积分
12
发表于 2019-12-27 06:49:07 | 显示全部楼层
金指头 发表于 2019-12-26 21:03
OUT:SIGNALS_USER(603,0)>0;
FK:INTPART(SIGNALS_USER(604,0));
X_1:=OUT OR OUT AND 1;

太厉害了,谢谢老师。
金达牛短线伴侣

2

主题

8

帖子

10

积分

新手上路

Rank: 1

积分
10
发表于 2019-12-27 20:21:40 | 显示全部楼层
帮忙和谐谢谢

实战突破跟踪主图套装.zip

59.89 KB, 下载次数: 33

金达牛短线伴侣

2

主题

16

帖子

16

积分

新手上路

Rank: 1

积分
16
 楼主| 发表于 2019-12-28 13:52:10 | 显示全部楼层

王仁元

王仁远.rar

4.19 KB, 下载次数: 35

金达牛短线伴侣

2

主题

13

帖子

15

积分

新手上路

Rank: 1

积分
15
发表于 2019-12-29 17:42:51 | 显示全部楼层
谢谢老师
金达牛短线伴侣
回复

使用道具 举报

0

主题

3

帖子

3

积分

新手上路

Rank: 1

积分
3
发表于 2019-12-29 17:43:25 | 显示全部楼层
本帖最后由 lkair 于 2019-12-29 18:03 编辑


求版主和谐、感谢版主

犇剑出鞘.zip (7.08 KB, 下载次数: 26)
金达牛短线伴侣

0

主题

3

帖子

3

积分

新手上路

Rank: 1

积分
3
发表于 2020-1-4 22:12:41 | 显示全部楼层
咋没人呢?老师呢
金达牛短线伴侣

0

主题

2

帖子

2

积分

新手上路

Rank: 1

积分
2
发表于 2020-2-20 17:42:18 | 显示全部楼层
请老师和谐下这个公式

老鸭头 - 副本.rar

2.17 KB, 下载次数: 13

金达牛短线伴侣

0

主题

4

帖子

4

积分

新手上路

Rank: 1

积分
4
发表于 2020-3-5 23:17:33 | 显示全部楼层
谢谢分享!!!
金达牛短线伴侣
回复

使用道具 举报

0

主题

1

帖子

1

积分

新手上路

Rank: 1

积分
1
发表于 2020-3-7 21:58:52 | 显示全部楼层

DRAWTEXT_FIX(1,0.00,0.01,0,'一、异动原因:'),COLORRED;
DRAWTEXT_FIX(1,0.00,0.08,0,EXTERNSTR(0,881)),COLORWHITE;
DRAWTEXT_FIX(1,0.00,0.15,0,EXTERNSTR(0,882)),COLORWHITE;
DRAWTEXT_FIX(1,0.00,0.22,0,'二、个股点评:'),COLORRED;
DRAWTEXT_FIX(1,0.00,0.29,0,EXTERNSTR(0,884)),COLORWHITE;
DRAWTEXT_FIX(1,0.00,0.36,0,'三、涨停原因:'),COLORRED;
DRAWTEXT_FIX(1,0.00,0.43,0,EXTERNSTR(0,883)),COLORWHITE;
DRAWTEXT_FIX(1,0.00,0.50,0,'四、最新消息:'),COLORRED;
DRAWTEXT_FIX(1,0.00,0.57,0,EXTERNSTR(0,815)),COLORLIGRAY;





0;
20;





净流入:INTPART(SIGNALS_USER(201,0)),COLORRED,NODRAW;

高胜率买数:INTPART(SIGNALS_USER(707,0)),COLORRED,NODRAW;
高胜率卖数:INTPART(SIGNALS_USER(708,0)),COLORRED,NODRAW;

机构买数:INTPART(SIGNALS_USER(206,0)),COLORRED,NODRAW;
机构卖数:INTPART(SIGNALS_USER(207,0)),COLORRED,NODRAW;


JGBUY:=IF(SIGNALS_USER(208,0)=DRAWNULL,0,SIGNALS_USER(208,0));

JGSELL:=IF(SIGNALS_USER(209,0)=DRAWNULL,0,SIGNALS_USER(209,0));

机构买量:INTPART(JGBUY),COLORRED,NODRAW;
机构卖量:INTPART(JGSELL),COLORRED,NODRAW;

机构净买量:=INTPART((机构买量+机构卖量)),COLORRED,NODRAW;


TBUY:=IF(SIGNALS_USER(701,0)=DRAWNULL,0,SIGNALS_USER(701,0));

TSELL:=IF(SIGNALS_USER(702,0)=DRAWNULL,0,SIGNALS_USER(702,0));


做T机构总买:INTPART(TBUY),COLORRED,NODRAW;

做T机构总卖:INTPART(TSELL),COLORRED,NODRAW;

做T机构买卖方向:INTPART(SIGNALS_USER(703,0)),COLORRED,NODRAW;

做T机构净流入:INTPART((做T机构总买+做T机构总卖)),COLORRED,NODRAW;



STICKLINE(净流入>0,0,4,1,0),COLORRED;
STICKLINE(净流入<0,0,4,1,0),COLORGREEN;

STICKLINE(高胜率买数>高胜率卖数,0,3,2,0),COLORRED;
STICKLINE(高胜率买数<高胜率卖数,0,3,2,0),COLORGREEN;


STICKLINE(机构净买量>0,0,2,3,0),COLORRED;
STICKLINE(机构净买量<0,0,2,3,0),COLORGREEN;


STICKLINE(做T机构净流入>0,0,1,4,0),COLORMAGENTA;
STICKLINE(做T机构净流入<0,0,1,4,0),COLORGREEN;


ZD:=ABS(机构净买量) OR MAX(高胜率买数,高胜率卖数) OR ABS(做T机构净流入)  ;

DRAWTEXT(做T机构净流入>0,M+3*K,VARCAT(VARCAT(VARCAT(VARCAT(VARCAT('做T总买:',VAR2STR(做T机构总买,0)),'-总卖:'),VAR2STR(做T机构总卖,0)),'-近: '),VAR2STR(做T机构买卖方向,0))),COLORMAGENTA;


DRAWTEXT(ZD>0,M+K,VARCAT(VARCAT(VARCAT('高:',VAR2STR(高胜率买数,0)),'-'),VAR2STR(高胜率卖数,0))),COLORYELLOW;
DRAWTEXT(ZD>0,M+2*K,VARCAT(VARCAT(VARCAT('机:',VAR2STR(机构买数,0)),'-'),VAR2STR(机构卖数,0))),COLORYELLOW;


DRAWTEXT(1 AND 净流入>0,M,VARCAT('净:',VAR2STR(净流入,0))),COLORRED;
DRAWTEXT(1 AND 净流入<0,M,VARCAT('净:',VAR2STR(净流入,0))),COLORGREEN;






金达牛短线伴侣

0

主题

5

帖子

5

积分

新手上路

Rank: 1

积分
5
QQ
发表于 2020-3-11 20:54:55 | 显示全部楼层
楼主有无机构进出分时和能够显示形态和画线压力的主图指标啊?能不能分享一个学习下
金达牛短线伴侣

5

主题

9

帖子

14

积分

新手上路

Rank: 1

积分
14
发表于 2020-4-2 18:05:06 | 显示全部楼层
请老师和谐

至尊量柱.zip

14.24 KB, 下载次数: 12

金达牛短线伴侣

0

主题

3

帖子

3

积分

新手上路

Rank: 1

积分
3
发表于 2020-4-7 17:10:08 | 显示全部楼层
本帖最后由 dzb123 于 2020-4-10 17:22 编辑

请老师和谐

鳄鱼三线_指.zip

16.35 KB, 下载次数: 11

鳄鱼三线选.zip

3.65 KB, 下载次数: 8

金达牛短线伴侣

0

主题

3

帖子

3

积分

新手上路

Rank: 1

积分
3
发表于 2020-4-10 07:31:05 | 显示全部楼层
至尊量柱
X_1:=AMOUNT/100000000;
X_2:=REF(AMOUNT,1)/100000000;
比值:X_1/X_2;
DRAWTEXT(CURRBARSCOUNT=2 OR CURRBARSCOUNT=1,VOL*1.4,VARCAT(VAR2STR(X_1,2),3777)),COLORWHITE;
量:VOL,VOLSTICK,COLORLIGRAY;
几倍:VOL/REF(VOL,1),NODRAW,COLORRED;
换手:VOL*10000/FINANCE(7),NODRAW,COLORGREEN;
量比:VOL/REF(MA(VOL,5),1),NODRAW,COLORBROWN;
全换手周期:SUMBARS(VOL,CAPITAL),NODRAW,COLORLIGREEN;
X_3:=EMA(VOL,5);
X_4:=EMA(VOL,60);
X_5:=AMOUNT/VOL/100;
X_6:=X_5>REF(CLOSE,1) AND REF(OPEN,1)>REF(CLOSE,1) AND OPEN>REF(MAX(OPEN,CLOSE),1) AND VOL<=REF(VOL,1) AND CLOSE>OPEN;
X_7:=VOL=HHV(VOL,21);
STICKLINE(CLOSE>OPEN AND X_7,VOL*4/5,VOL,2,0),COLORWHITE;
STICKLINE(CLOSE>OPEN AND X_7,VOL*4/5,VOL,0.6,0),COLORGREEN;
X_8:=20;
X_9:=60;
X_10:=100;
低量20:VOL=LLV(VOL,X_8) AND BARSCOUNT(VOL)>=X_8,NODRAW,COLORGREEN;
低量60:VOL=LLV(VOL,X_9) AND BARSCOUNT(VOL)>=X_9,NODRAW,COLORBLUE;
地量:VOL=LLV(VOL,X_10) AND BARSCOUNT(VOL)>=X_10,NODRAW,COLORGRAY;
STICKLINE(低量20,VOL*2/3,VOL,3,0),COLORGRAY;
STICKLINE(低量20,VOL*1/3,VOL*2/3,3,0),COLORYELLOW;
STICKLINE(低量20,0,VOL*1/3,3,0),COLORFF0088;
STICKLINE(低量60,VOL*1/2,VOL,3,0),COLORGRAY;
STICKLINE(低量60,0,VOL*1/2,3,0),COLORYELLOW;
STICKLINE(地量,0,VOL,3,0),COLORGRAY;
VOLUME:VOL,VOLSTICK;
|:COUNT(CLOSE>REF(CLOSE,1),2)=2 AND COUNT(VOL<REF(VOL,1),2)=2;
X_11:=DYNAINFO(8)>0;
VO:VOL=LLV(VOL,100) AND X_11;
百日地量柱:X_11 AND VO,COLORCYAN;
STICKLINE(百日地量柱,0,VOL,2,0),COLORCYAN;
DRAWTEXT(百日地量柱,VOL+3000,54),COLORCYAN;
X_12:=VOL>REF(VOL,1)*1.8;
X_13:=VOL<REF(LLV(VOL,13),1);
X_14:=VOL<REF(LLV(VOL,55),1);
STICKLINE(X_12,0,VOL,2,0),COLORYELLOW;
X_15:=X_12;
X_16:=(3*CLOSE+HIGH+LOW+OPEN)/6;
X_17:=(8*X_16+7*REF(X_16,1)+6*REF(X_16,2)+5*REF(X_16,3)+4*REF(X_16,4)+3*REF(X_16,5)+2*REF(X_16,6)+REF(X_16,8))/36;
X_18:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>X_17 AND CLOSE>OPEN;
X_19:=VOL>REF(VOL,1)*0.98 AND VOL<REF(VOL,1)*1.02;
STICKLINE(X_19,0,VOL,2,0),COLORWHITE;
X_20:=X_19;
X_21:=VOL<=REF(VOL,1)*0.505;
STICKLINE(X_21,0,VOL,2,0),COLORMAGENTA;
X_22:=VOL/REF(VOL,1)>0.505 AND VOL/REF(VOL,1)<0.66;
STICKLINE(X_22,0,VOL*1/3,2,0),COLORGREEN;
STICKLINE(X_22,VOL*1/3,VOL*2/3,2,0),COLORBLACK;
STICKLINE(X_22,VOL*2/3,VOL,2,0),COLORRED;
STICKLINE(X_21,0,VOL*1/2,2,0),COLORGREEN;
STICKLINE(X_21,VOL*1/2,VOL,2,0),COLORMAGENTA;
X_23:=CLOSE/REF(CLOSE,1)<=0.96 AND VOL<HHV(VOL,30)/1.9;
STICKLINE(X_23,0,VOL,0.8,0),COLORWHITE;
STICKLINE(X_23,0,VOL,0.3,0),COLORFF0088;
X_24:=(VOL+OPEN)/2;
STICKLINE(CLOSE>OPEN,X_24,X_24,(-1),0),COLORBLACK;
STICKLINE(CLOSE<OPEN,X_24,X_24,(-1),0),COLORWHITE;
低量柱:IF(CURRBARSCOUNT<=CONST(REF(LLVBARS(VOL,30),1)+1)+1,CONST(REF(VOL,REF(LLVBARS(VOL,30),1)+1)),DRAWNULL),COLORWHITE,LINETHICK7;
低量柱1:IF(CURRBARSCOUNT<=CONST(REF(LLVBARS(VOL,30),1)+1)+1,CONST(REF(VOL,REF(LLVBARS(VOL,30),1)+1)),DRAWNULL),COLORRED,LINETHICK2;
标志线21:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,21),1)+1)+1,CONST(REF(VOL,REF(HHVBARS(VOL,21),1)+1)),DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=CONST(REF(HHVBARS(VOL,21),1))+2,VOL*1.01,STRCAT(CON2STR(CONST(CONST(REF(HHVBARS(VOL,21),1))+1),0),3780)),COLORYELLOW;
X_25:=IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,21),1)+1)+1,CONST(REF(MAX(OPEN,CLOSE),REF(HHVBARS(VOL,21),1)+1)),DRAWNULL);
DRAWTEXT(ISLASTBAR,标志线21,CON2STR(X_25,2)),COLORYELLOW;
X_26:=IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,21),1)+1)+1,CONST(REF(MIN(CLOSE,OPEN),REF(HHVBARS(VOL,21),1)+1)),DRAWNULL);
金达牛短线伴侣

1

主题

6

帖子

7

积分

新手上路

Rank: 1

积分
7
发表于 2020-4-11 21:26:44 | 显示全部楼层
XA_1:=MA(CLOSE,5);
XA_2:=MA(CLOSE,10);
XA_3:=MA(CLOSE,60);
XA_4:=BARSLAST(CROSS(XA_1,XA_3));
XA_5:=BARSLAST(CROSS(XA_2,XA_3));
XA_6:=BARSLAST(HIGH=HHV(HIGH,XA_4));
XA_7:=BARSLAST(CROSS(XA_2,XA_1));
XA_8:=BARSLAST(CROSS(XA_1,XA_2));
XA_9:=ATAN((XA_1/REF(XA_1,1)-1)*100)*180/3.14159;
老鸭头:COUNT(XA_9>60,20)>=5 AND XA_1>XA_3 AND XA_2>XA_3 AND XA_4-XA_6>3 AND XA_5-XA_6>3 AND XA_7-XA_8<=6 AND (CROSS(CLOSE,XA_2) OR CROSS(XA_1,XA_2)),COLORMAGENTA,LINETHICK3;
金达牛短线伴侣

1

主题

6

帖子

7

积分

新手上路

Rank: 1

积分
7
发表于 2020-4-11 21:30:37 | 显示全部楼层
{公式名称: 鳄鱼三线
公式描述:
参数数量: 3
参数1: 沉睡周期, 最小: 3, 最大: 100, 缺省: 40, 1分钟线: 0, 5分钟线: 0, 15分钟线: 0, 30分钟线: 0, 60分钟线: 0, 日线: 0, 周线: 0, 月线: 0, 45天线: 0, 季线: 0, 年线: 0, 未知周期_1: 0, 未知周期_2: 0, 未知周期_3: 0, 未知周期_4: 0, 未知周期_5: 0, 未知周期_6: 0, 未知周期_7: 0, 未知周期_8: 0, 未知周期_9: 0, 未知周期_10: 0, 未知周期_11: 0, 未知周期_12: 0, 未知周期_13: 0, 未知周期_14: 0
参数2: 沉睡振幅, 最小: 5, 最大: 30, 缺省: 30, 1分钟线: 0, 5分钟线: 0, 15分钟线: 0, 30分钟线: 0, 60分钟线: 0, 日线: 0, 周线: 0, 月线: 0, 45天线: 0, 季线: 0, 年线: 0, 未知周期_1: 0, 未知周期_2: 0, 未知周期_3: 0, 未知周期_4: 0, 未知周期_5: 0, 未知周期_6: 0, 未知周期_7: 0, 未知周期_8: 0, 未知周期_9: 0, 未知周期_10: 0, 未知周期_11: 0, 未知周期_12: 0, 未知周期_13: 0, 未知周期_14: 0
参数3: 三金叉周期, 最小: 3, 最大: 20, 缺省: 15, 1分钟线: 0, 5分钟线: 0, 15分钟线: 0, 30分钟线: 0, 60分钟线: 0, 日线: 0, 周线: 0, 月线: 0, 45天线: 0, 季线: 0, 年线: 0, 未知周期_1: 0, 未知周期_2: 0, 未知周期_3: 0, 未知周期_4: 0, 未知周期_5: 0, 未知周期_6: 0, 未知周期_7: 0, 未知周期_8: 0, 未知周期_9: 0, 未知周期_10: 0, 未知周期_11: 0, 未知周期_12: 0, 未知周期_13: 0, 未知周期_14: 0
公式类型: 技术指标公式-其他类型
画线方法: 主图叠加
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:
请设置计算参数:
沉睡周期: Param#0 (3.00--100.00)
沉睡振幅: Param#1 (5.00--30.00)
三金叉周期: Param#2 (3.00--20.00)
用法注释:无
公式源码:}
XA_1:=CLOSE>REF(CLOSE,1);
XA_2:=VOL<REF(VOL,1);
XA_3:=XA_1 AND XA_2;
DRAWICON(XA_3 AND 0,LOW,38);
MA1:MA(CLOSE,5),COLORRED;
MA2:MA(CLOSE,8),COLORYELLOW;
MA3:MA(CLOSE,13),COLORBLUE;
XA_4:=MA(CLOSE,5);
XA_5:=MA(CLOSE,8);
XA_6:=MA(CLOSE,13);
MA60:MA(CLOSE,60),POINTDOT,COLORGREEN;
NOTEXT_MA60_1:IF(MA60>=REF(MA60,1),MA60,DRAWNULL),DOTLINE,COLORGREEN;
XA_7:=40;
XA_8:=30;
XA_9:=15;
XA_10:=CROSS(XA_5,XA_4);
XA_11:=CROSS(XA_6,XA_4);
XA_12:=CROSS(XA_6,XA_5);
XA_13:=FINDLOW(LOW,0,XA_7,1);
XA_14:=FINDHIGH(HIGH,0,XA_7,1);
XA_15:=(XA_14-XA_13)*100/CLOSE;
XA_16:=COUNT(XA_10,XA_7)>=2 AND COUNT(XA_11,XA_7)>=2 AND COUNT(XA_12,XA_7)>=2 AND XA_15<=XA_8;
XA_17:=CROSS(XA_4,XA_5);
XA_18:=CROSS(XA_4,XA_6);
XA_19:=CROSS(XA_5,XA_6);
XA_20:=EXIST(XA_17,XA_9) AND EXIST(XA_19,XA_9) AND EXIST(XA_18,XA_9) AND XA_4>=XA_5 AND XA_5>=XA_6;
XA_21:=LOW>REF(HIGH,1);
XA_22:=MIN(CLOSE,OPEN)>REF(MAX(CLOSE,OPEN),1);
XA_23:=XA_16 AND XA_20 AND XA_21;
XA_24:=XA_16 AND XA_20 AND XA_22 AND NOT(XA_21);
鳄三线:IF(XA_16,IF(XA_20,IF(XA_21,4,IF(XA_22,3,2)),1),0),NODRAW,COLORMAGENTA;
DRAWICON(XA_24,LOW,34);
DRAWICON(XA_23,LOW,38);
XA_25:=NAMELIKE(1) OR NAMELIKE(2);
XA_26:=IF(NAMELIKE(83) OR NAMELIKE(84) OR NAMELIKE(85) OR NAMELIKE(86),0,IF(CODELIKE(7),1,2));
XA_27:=0.98;
XA_28:=0.95;
XA_29:=1.02;
XA_30:=1.05;
XA_31:=IF(XA_25,CLOSE>=1.05*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000),CLOSE>=1.1*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000)) AND PERIOD=5;
XA_32:=IF(XA_25,CLOSE<=0.95*REF(CLOSE,1)+51/IF(CLOSE>=1,10000,100000),CLOSE<=0.9*REF(CLOSE,1)+51/IF(CLOSE>=1,10000,100000)) AND PERIOD=5;
XA_33:=IF(XA_25,HIGH>=1.05*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000),HIGH>=1.1*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000)) AND PERIOD=5;
XA_34:=IF(XA_25,LOW<=0.95*REF(CLOSE,1)+51/IF(CLOSE>=1,10000,100000),LOW<=0.9*REF(CLOSE,1)+51/IF(CLOSE>=1,10000,100000)) AND PERIOD=5;
XA_35:=IF(XA_25,CLOSE>=1.025*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000),CLOSE>=1.05*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000));
XA_36:=IF(XA_25,CLOSE<=0.975*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000),CLOSE<=0.95*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000));
XA_37:=IF(XA_25,CLOSE>=1.3*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000),CLOSE>=1.5*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000));
XA_38:=IF(XA_25,CLOSE<=0.7*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000),CLOSE<=0.5*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000));
XA_39:=IF(XA_25,CLOSE>=1.1*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000),CLOSE>=1.2*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000));
XA_40:=IF(XA_25,CLOSE<=0.9*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000),CLOSE<=0.8*REF(CLOSE,1)-49/IF(CLOSE>=1,10000,100000));
XA_41:=PERIOD=5 AND XA_35 OR (PERIOD=6 AND XA_39) OR (PERIOD=7 AND XA_37);
XA_42:=PERIOD=5 AND XA_36 OR (PERIOD=6 AND XA_40) OR (PERIOD=7 AND XA_38);
开幅OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100,NODRAW,COLORYELLOW;
高幅HIGH-REF(CLOSE,1))/REF(CLOSE,1)*100,NODRAW,COLORYELLOW;
低幅LOW-REF(CLOSE,1))/REF(CLOSE,1)*100,NODRAW,COLORYELLOW;
实幅CLOSE-OPEN)/REF(CLOSE,1)*100,NODRAW,COLORYELLOW;
振幅HIGH-LOW)/REF(CLOSE,1)*100,NODRAW,COLORLIMAGENTA;
流值:FINANCE(7)*CLOSE/100000000,NODRAW,COLORLIBLUE;
总值:FINANCE(1)*CLOSE/100000000,NODRAW,COLORLIBLUE;
报期:FINANCE(37),NODRAW,COLORYELLOW;
收益:FINANCE(38),NODRAW,COLORYELLOW;
同增:FINANCE(43),NODRAW,COLORYELLOW;
STICKLINE(PERIOD=5 AND XA_33,HIGH,MAX(CLOSE,OPEN),0.2,0),COLORMAGENTA;
STICKLINE(PERIOD=5 AND XA_34,LOW,MIN(CLOSE,OPEN),0.2,0),COLORBLUE;
STICKLINE(XA_41,OPEN,CLOSE,0.5,0),COLORRED;
STICKLINE(XA_42,OPEN,CLOSE,0.5,0),COLORBROWN;
STICKLINE(PERIOD=5 AND XA_31,OPEN,CLOSE,(-1),0),COLORMAGENTA;
STICKLINE(PERIOD=5 AND XA_32,OPEN,CLOSE,(-1),0),COLORBLUE;
DRAWTEXT_FIX(1,0,0.05,0,FGBLOCK),COLORGRAY;
DRAWTEXT_FIX(1,0,0,0,HYBLOCK),COLORMAGENTA;
DRAWTEXT_FIX(1,0.04,0,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.08,0,0,GNBLOCK),COLORGREEN;
DRAWTEXT_FIX(1,0.48,0,0,ZDBLOCK),COLORYELLOW;


{公式名称: 鳄鱼三线选1
公式描述:
参数数量: 4
参数1: 沉睡周期, 最小: 5, 最大: 250, 缺省: 40
参数2: 沉睡振幅, 最小: 10, 最大: 30, 缺省: 30
参数3: 三金叉周期, 最小: 2, 最大: 30, 缺省: 15
参数4: 是否腾空阳, 最小: 0, 最大: 2, 缺省: 0
公式类型: 条件选股公式-其他类型
公式版本: 0

参数精灵:
请设置计算参数:
沉睡周期: Param#0 (5.00--250.00)
沉睡振幅: Param#1 (10.00--30.00)
三金叉周期: Param#2 (2.00--30.00)
是否腾空阳: Param#3 (0.00--2.00)
用法注释:
是否腾空阳:0表示不判断跳空、1隐性跳空或显性跳空、2显性跳空
三金叉周期:就是在该周期内出现了均线1上穿均线2,均线1上穿均线3,均线2上穿均线3,表示鳄鱼刚张嘴
公式源码:}
XA_1:=MA(CLOSE,5);
XA_2:=MA(CLOSE,8);
XA_3:=MA(CLOSE,13);
XA_4:=CROSS(XA_2,XA_1);
XA_5:=CROSS(XA_3,XA_1);
XA_6:=FINDLOW(LOW,0,沉睡周期,1);
XA_7:=FINDHIGH(HIGH,0,沉睡周期,1);
XA_8:=(XA_7-XA_6)*100/CLOSE;
XA_9:=COUNT(XA_4,沉睡周期)>=2 AND COUNT(XA_5,沉睡周期)>=2 AND XA_8<=沉睡振幅;
XA_10:=CROSS(XA_1,XA_2);
XA_11:=CROSS(XA_1,XA_3);
XA_12:=CROSS(XA_2,XA_3);
XA_13:=EXIST(XA_10,三金叉周期) AND EXIST(XA_12,三金叉周期) AND EXIST(XA_11,三金叉周期) AND CLOSE>=XA_1 AND XA_1>=XA_2 AND XA_2>=XA_3;
XA_14:=LOW>REF(HIGH,1);
XA_15:=MIN(CLOSE,OPEN)>REF(MAX(CLOSE,OPEN),1);
三线:XA_9 AND XA_13 AND (是否腾空阳=0 OR (是否腾空阳=1 AND XA_15) OR (是否腾空阳=2 AND XA_14));
金达牛短线伴侣

0

主题

6

帖子

6

积分

新手上路

Rank: 1

积分
6
发表于 2020-12-21 17:03:21 | 显示全部楼层
老师,厉害了!
金达牛短线伴侣

0

主题

2

帖子

2

积分

新手上路

Rank: 1

积分
2
发表于 2021-4-5 10:34:13 | 显示全部楼层
好贴 !
金达牛短线伴侣
回复

使用道具 举报

0

主题

1

帖子

1

积分

新手上路

Rank: 1

积分
1
发表于 2021-6-20 07:05:32 | 显示全部楼层
请老师和谐

nxz-03.rar

2.91 KB, 下载次数: 2

金达牛短线伴侣

0

主题

1

帖子

1

积分

新手上路

Rank: 1

积分
1
发表于 2021-8-12 13:46:54 | 显示全部楼层
请老师和谐

抄底A☆_0.rar

22.24 KB, 下载次数: 1

金达牛短线伴侣

16

主题

103

帖子

119

积分

注册会员

Rank: 2

积分
119
发表于 2021-8-14 00:20:20 | 显示全部楼层

{公式名称: 抄底追击☆
公式描述:
无参数
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
DRAWGBK(CLOSE>0,RGB(0,108,108),RGB(88,0,0),0,5,0);
XA_1:=1;
XA_2:=REF(LLV(LOW,90),3)*XA_1;
XA_3:=REFDATE(XA_2,DATE);
XA_4:=XA_3=LOW AND (CLOSE-LOW>OPEN-CLOSE OR OPEN-LOW>CLOSE-OPEN);
XA_5:=REF(HHV(LOW,70),3)*XA_1;
XA_6:=REFDATE(XA_5,DATE);
XA_7:=XA_6=HIGH AND (HIGH-CLOSE>CLOSE-OPEN OR HIGH-OPEN>CLOSE-OPEN);
XA_8:=REF(HHV(HIGH,150),3)*XA_1;
XA_9:=REFDATE(XA_8,DATE);
XA_10:=REFDATE(XA_9,DATE);
XA_11:=XA_10=HIGH AND (CLOSE-LOW<OPEN-CLOSE OR OPEN-LOW<CLOSE-OPEN);
XA_12:=REF(LLV(LOW,150),3)*XA_1;
XA_13:=REFDATE(XA_12,DATE);
XA_14:=REFDATE(XA_13,DATE);
XA_15:=XA_14=LOW AND (CLOSE+LOW<OPEN+CLOSE OR OPEN+LOW<CLOSE+OPEN);
XA_16:=REF(LOW,1)*XA_1;
XA_17:=SMA(ABS(LOW-XA_16),13,1)/SMA(MAX(LOW-XA_16,0),13,1)*100*XA_1;
XA_18:=EMA(IF(CLOSE*1.2,XA_17*13,XA_17/13),13);
XA_19:=LLV(LOW,34)*XA_1;
XA_20:=HHV(XA_18,34)*XA_1;
XA_21:=IF(LLV(LOW,56),1,0);
XA_22:=EMA(IF(LOW<=XA_19,(XA_18+XA_20*2)/2,0),3)/618*XA_21;
XA_23:=XA_22>REF(XA_22,1);
XA_24:=REF(LLV(LOW,100),3);
XA_25:=REFDATE(XA_24,DATE);
XA_26:=LOW=XA_25;
XA_27:=XA_23 AND XA_26;
XA_28:=XA_27>REF(XA_27,1);
XA_29:=XA_28>REF(XA_28,1);
XA_30:=CROSS(EMA(CLOSE,19),EMA(CLOSE,7));
XA_31:=CROSS(EMA(CLOSE,7),EMA(CLOSE,19));
XA_32:=LOW=LLV(LOW,BARSLAST(XA_30)+1);
XA_33:=LLV(LOW,BARSLAST(XA_30)+1);
XA_34:=HIGH=HHV(HIGH,BARSLAST(XA_31)+1);
XA_35:=HHV(HIGH,BARSLAST(XA_31)+1);
XA_36:=DRAWLINE(XA_32,XA_33,XA_34,XA_35,0);
XA_37:=HIGH=HHV(HIGH,BARSLAST(XA_31)+1);
XA_38:=HHV(HIGH,BARSLAST(XA_31)+1);
XA_39:=LOW=LLV(LOW,BARSLAST(XA_30)+1);
XA_40:=LLV(LOW,BARSLAST(XA_30)+1);
XA_41:=DRAWLINE(XA_37,XA_38,XA_39,XA_40,0);
XA_42:=IF(XA_41<REF(XA_41,1) AND XA_41=XA_36,1,0);
XA_43:=IF(REF(XA_42,1)=0 AND XA_42>=1,1,0);
XA_44:=3;
XA_45:=MA(HHV(HIGH,485),17)*XA_1;
XA_46:=MA(HHV(HIGH,222),17)*XA_1;
XA_47:=MA(HHV(HIGH,96),17)*XA_1;
XA_48:=MA(LLV(LOW,485),17)*XA_1;
XA_49:=MA(LLV(LOW,222),17)*XA_1;
XA_50:=MA(LLV(LOW,96),17)*XA_1;
XA_51:=MA((XA_48*0.96+XA_49*0.96+XA_50*0.96+XA_45*0.558+XA_46*0.558+XA_47*0.558)/6,17);
XA_52:=MA((XA_48*1.25+XA_49*1.23+XA_50*1.2+XA_45*0.55+XA_46*0.55+XA_47*0.65)/6,17);
XA_53:=MA((XA_48*1.3+XA_49*1.3+XA_50*1.3+XA_45*0.68+XA_46*0.68+XA_47*0.68)/6,17);
XA_54:=MA((XA_51*3+XA_52*2+XA_53)/6*1.738,17);
XA_55:=IF(1,XA_54,XA_54*DAY);
XA_56:=LOW;
XA_57:=REF(LOW,1);
XA_58:=SMA(ABS(XA_56-XA_57),3,1)/SMA(MAX(XA_56-XA_57,0),XA_44,1)*100;
XA_59:=MA(IF(CLOSE*1.35<=XA_55,XA_58*10,XA_58/10),XA_44);
XA_60:=LLV(LOW,30)*XA_1;
XA_61:=HHV(XA_59,30)*XA_1;
XA_62:=1;
XA_63:=IF(1,MA(IF(LOW<=XA_60,(XA_59+XA_61*2)/2,0),XA_44),100000000);
XA_64:=IF(CLOSE<REF(CLOSE,1),VOL/CAPITAL*10053,0);
XA_65:=ABS(EMA(XA_64,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<(-0.04),1,0);
XA_66:=IF(XA_63>500 AND XA_63>2500,30,0);
XA_67:=IF(XA_63>10000 AND XA_63>20000,60,0);
XA_68:=IF(XA_63>30000 AND XA_63>30000,1,0);
XA_69:=WINNER(CLOSE*(1-30/100))-WINNER(CLOSE*(1+30/100))*100;
XA_70:=REF(LOW,1);
XA_71:=SMA(ABS(LOW-XA_70),13,1)/SMA(MAX(LOW-XA_70,0),13,1)*100;
XA_72:=EMA(IF(CLOSE*1.2,XA_71*13,XA_71/13),13);
XA_73:=LLV(LOW,34)*XA_1;
XA_74:=HHV(XA_72,34)*XA_1;
XA_75:=IF(LLV(LOW,56),1,0);
XA_76:=EMA(IF(LOW<=XA_73,(XA_72+XA_74*2)/2,0),3)/618*XA_75;
XA_77:=XA_76>REF(XA_76,1);
XA_78:=100;
XA_79:=3;
XA_80:=REF(LLV(LOW,100),3);
XA_81:=REFDATE(XA_80,DATE);
XA_82:=LOW=XA_81;
XA_83:=XA_77 AND XA_82;
XA_84:=XA_83>REF(XA_83,1);
XA_85:=XA_84>REF(XA_84,1);
XA_86:=XA_4+XA_15+XA_29+XA_43+XA_85+XA_68>=3;
XA_87:=CROSS(CLOSE/MA(CLOSE,20)-1,2.1*STD(CLOSE,20)/MA(CLOSE,20)) AND CROSS(CLOSE/MA(CLOSE,20)-1,1.3*STD(CLOSE,20)/MA(CLOSE,20));
XA_88:=MA(CLOSE,10);
XA_89:=MA(CLOSE,54);
XA_90:=(CLOSE-XA_89)/XA_89<0.1;
XA_91:=(CLOSE-XA_88)/XA_88<0.3;
XA_92:=(XA_87=1 AND XA_88=1)*0.2;
XA_93:=(XA_92=0 AND REF(XA_92,1)=0.2 AND REF(COUNT(XA_92=0.2,10)=10,1)=1)*(-0.1);
XA_94:=XA_93=(-0.1);
XA_95:=MA(VOL,5)*XA_1;
XA_96:=REF(XA_95,1);
XA_97:=VOL/XA_96>2 AND VOL/CAPITAL*100>3;
XA_98:=REF((HHV(HIGH,30)-LLV(LOW,30))/LLV(LOW,30),1)<=30/100 AND CLOSE>=REF(HHV(HIGH,30),1) AND BARSCOUNT(CLOSE)>30;
XA_99:=XA_97 AND XA_98 AND DYNAINFO(14)>0.03 AND DYNAINFO(17)>0.03;
XA_100:=XA_94+XA_99>0;
IF(XA_100,100,0),COLORMAGENTA;
DRAWICON(XA_100,100,34);
STICKLINE(XA_86,30*3,0.4*3,4.7,0),COLORYELLOW;
STICKLINE(XA_86,30*3,29.4*3,1,0),COLORYELLOW;
STICKLINE(XA_86,29.4*3,33*3,0,4.7),COLORRED;
STICKLINE(XA_86,29.4*3,33*3,4.7,0),COLORRED;
STICKLINE(XA_86,1*3,0*3,10,0),COLORRED;
STICKLINE(XA_86,2*3,0.4*3,8,0),COLORGREEN;
STICKLINE(XA_86,20*3,0*3,4.4,0),COLORYELLOW;
STICKLINE(XA_86,29*3,16*3,4,0),COLORBLACK;
STICKLINE(XA_86,16*3,15*3,4,0),COLORBLACK;
STICKLINE(XA_86,19.700001*3,4*3,4,0),COLORBLACK;
STICKLINE(XA_86,3*3,0*3,1,0),COLOR000066;
STICKLINE(XA_86,6*3,3*3,1,0),COLOR330066;
STICKLINE(XA_86,9*3,6*3,1,0),COLOR660066;
STICKLINE(XA_86,12*3,9*3,1,0),COLOR990099;
STICKLINE(XA_86,13*3,12*3,4.7,0),COLORGREEN;
STICKLINE(XA_86,15*3,12*3,1,0),COLORCC0066;
STICKLINE(XA_86,18*3,15*3,1,0),COLORFF0066;
STICKLINE(XA_86,16*3,15*3,4.7,0),COLORYELLOW;
STICKLINE(XA_86,18*3,19*3,4.7,0),COLORGREEN;
STICKLINE(XA_86,21*3,18*3,1,0),COLORFF00CC;
STICKLINE(XA_86,24*3,21*3,1,0),COLORCC00CC;
STICKLINE(XA_86,27*3,24*3,1,0),COLOR9900CC;
STICKLINE(XA_86,30*3,27*3,1,0),COLOR6600CC;

金达牛短线伴侣

0

主题

4

帖子

4

积分

新手上路

Rank: 1

积分
4
发表于 2021-9-18 10:13:06 | 显示全部楼层
请老师帮助和谐指标,谢谢。 龙回头预警_0.zip (7.26 KB, 下载次数: 1)
金达牛短线伴侣

0

主题

1

帖子

1

积分

新手上路

Rank: 1

积分
1
发表于 2021-9-21 10:30:25 | 显示全部楼层
请老师帮助和谐指标,谢谢。

波段顶底.rar

4.65 KB, 下载次数: 6

金达牛短线伴侣

16

主题

103

帖子

119

积分

注册会员

Rank: 2

积分
119
发表于 2021-10-29 22:23:40 | 显示全部楼层
小人物 发表于 2021-9-18 10:13
请老师帮助和谐指标,谢谢。

{公式名称: 龙回头预警
公式描述: 副图
无参数
公式类型: 技术指标公式-图表型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
XA_1:=5;
XA_2:=6;
XA_3:=6;
XA_4:=8;
XA_5:=IF(DATE<1900612,1,0);
XA_6:=(HIGH+MAX(CLOSE,OPEN))/2;
XA_7:=MA(XA_6,3);
XA_8:=(LOW+MIN(CLOSE,OPEN))/2;
XA_9:=MA(XA_8,3);
XA_10:=MA(XA_6,3);
XA_11:=(HIGH+LOW+CLOSE+OPEN)/4;
XA_12:=MA(XA_11,3);
XA_13:=REF((CLOSE+OPEN)/2,1)>REF((CLOSE+OPEN)/2,2) AND REF(MIN(CLOSE,OPEN),1)>REF(MAX(CLOSE,OPEN),2);
XA_14:=(MAX(XA_11,XA_12)-MIN(XA_11,XA_12))/MIN(XA_11,XA_12)*100;
XA_15:=(XA_12-(REF(XA_12,1)-XA_12)-LOW)/LOW*100;
XA_16:=(XA_7+(XA_7-REF(XA_7,1))-LOW)/LOW*100;
XA_17:=XA_12-(REF(XA_12,1)-XA_12);
XA_18:=XA_7+(XA_7-REF(XA_7,1));
XA_19:=IF(XA_13,XA_16,XA_15);
XA_20:=REF(EVERY(CLOSE>=OPEN,4),1) AND REF(EVERY((CLOSE+OPEN)/2>XA_12,4),1) AND (CLOSE+OPEN)/2<XA_12;
XA_21:=NOT(XA_20) AND (XA_12-OPEN)/OPEN*1000>5 AND OPEN<REF(MIN(CLOSE,OPEN),1);
XA_22:=SMA(LOW,4,3);
XA_23:=SMA(HIGH,4,3);
XA_24:=SMA(MIN(CLOSE,OPEN),4,3);
XA_25:=REF(LOW,1)-HHV(MAX(REF(LOW,2),REF(LOW,1))-MIN(REF(LOW,2),REF(LOW,1)),2);
XA_26:=REF((CLOSE+OPEN)/2,1)>REF((CLOSE+OPEN)/2,2);
XA_27:=LOW<=XA_25+XA_25*0.01 AND OPEN>REF(OPEN,2) AND OPEN>=REF(LOW,3) AND COUNT(CLOSE>OPEN,7)>3;
XA_28:=(XA_25-LOW)/LOW*100;
XA_29:=(REF(LOW,1)-XA_25)/XA_25*100;
XA_30:=(XA_22-LOW)/LOW>XA_1/1000;
XA_31:=XA_30;
XA_32:=(REF(HIGH,1)-OPEN)/OPEN*100-(REF(MAX(CLOSE,OPEN),2)-REF(MAX(CLOSE,OPEN),1))/REF(MAX(CLOSE,OPEN),1)*100;
XA_33:=IF(XA_26,XA_28,XA_32);
XA_34:=XA_28+XA_33>2;
XA_35:=IF(XA_26,XA_27,XA_34) AND XA_19>2;
XA_36:=XA_5 AND XA_31 AND XA_35;
XG:REF(XA_36,1) AND LOW<REF(LOW/0.995,1),COLORYELLOW;
金达牛短线伴侣

16

主题

103

帖子

119

积分

注册会员

Rank: 2

积分
119
发表于 2021-10-29 22:29:19 | 显示全部楼层
AQ36518 发表于 2021-9-21 10:30
请老师帮助和谐指标,谢谢。

{公式名称: 波段做顶底
公式描述:
无参数
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
XA_1:=CLOSE-REF(CLOSE,1);
XA_2:=100*EMA(EMA(XA_1,6),6)/EMA(EMA(ABS(XA_1),6),6);
XA_3:=CROSS(EMA(CLOSE,19),EMA(CLOSE,7));
XA_4:=CROSS(EMA(CLOSE,7),EMA(CLOSE,19));
XA_5:=LOW=LLV(LOW,BARSLAST(XA_3)+1);
XA_6:=LLV(LOW,BARSLAST(XA_3)+1);
XA_7:=HIGH=HHV(HIGH,BARSLAST(XA_4)+1);
XA_8:=HHV(HIGH,BARSLAST(XA_4)+1);
XA_9:=DRAWLINE(XA_5,XA_6,XA_7,XA_8,0);
XA_10:=HIGH=HHV(HIGH,BARSLAST(XA_4)+1);
XA_11:=HHV(HIGH,BARSLAST(XA_4)+1);
XA_12:=LOW=LLV(LOW,BARSLAST(XA_3)+1);
XA_13:=LLV(LOW,BARSLAST(XA_3)+1);
XA_14:=DRAWLINE(XA_10,XA_11,XA_12,XA_13,0);
XA_15:=LLV(XA_2,2)=LLV(XA_2,7);
XA_16:=COUNT(XA_2<0,2);
XA_17:=CROSS(XA_2,MA(XA_2,2));
XA_18:=REF(XA_14,1)<REF(XA_14,2);
XA_19:=XA_9>REF(XA_14,1);
买点:XA_15 AND XA_16 AND XA_17 AND XA_18 AND XA_19;
XA_20:=IF(XA_9<REF(XA_9,1) AND XA_14=XA_9,1,0);
XA_21:=IF(XA_14<REF(XA_14,1) AND XA_14=XA_9,1,0);
持币:IF(XA_14<REF(XA_14,1) AND XA_14<XA_9,23,0),STICK,COLOR000088,LINETHICK3;
STICKLINE(XA_14<REF(XA_14,1),0,35,2,0),COLOR006600;
逃顶:IF(REF(XA_20,1)=0 AND XA_20>=1,60,0),STICK,COLORCYAN,LINETHICK5;
抄底:IF(REF(XA_21,1)=0 AND XA_21>=1,60,0),STICK,COLORRED,LINETHICK3;
金达牛短线伴侣

16

主题

103

帖子

119

积分

注册会员

Rank: 2

积分
119
发表于 2021-10-29 22:32:29 | 显示全部楼层

{公式名称: NXZ03
公式描述: 枪打出头鸟战法
无参数
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:
NXZ03  枪打出头鸟战法
公式源码:}
XA_1:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
XA_2:=SMA(XA_1,3,1);
XA_3:=XA_2;
XA_4:=3*XA_2-2*SMA(XA_2,2,1);
36,DOTLINE,COLORRED;
89.300003,COLOR696969,LINETHICK2;
STICKLINE(CLOSE>0,36,89,5,0),COLORGRAY;
XA_5:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
XA_6:=SMA(XA_5,3,1);
XA_7:=3*XA_6-2*SMA(XA_6,2,1);
STICKLINE(MAX(XA_4,XA_7)>89,89,MAX(XA_4,XA_7),4,0),COLORYELLOW;
DRAWBAND(XA_4,RGB(239,0,0),XA_7,RGB(0,218,0));
A1:XA_4,COLORYELLOW;
A2:XA_7,COLORDDDDDD;
金达牛短线伴侣
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关闭

站长推荐上一条 /1 下一条

手机版|金达牛短线伴侣

GMT+8, 2022-5-25 08:17 , Processed in 0.359237 second(s), 25 queries .

股市圈子 X3.4

Copyright © 2001-2022, JinDaNiu Inc.

快速回复 返回顶部 返回列表